This help page explains the causes of the file upload error due to no transactions are found or data is locked and how to resolve them.
Contents
1.Cause and solution when no transactions are found
Cause
The transactions in the file have already been uploaded
You are trying to upload trades that are dated on or before the latest transaction timestamp already uploaded in the same upload box. Cryptact only processes trade records after the most recent uploaded trade to avoid double counting. If you upload only past transactions, the error will occur.
▼How to check the ‘Latest transaction time’: it is displayed at the bottom of each upload box (see the example from Coincheck).
Solution
Delete the file you want to upload after the earliest transaction date from the list of transactions, and reupload the files in the order of the earliest transaction date.
- The data will be completely deleted from the server and cannot be restored.
- If you need to delete the trade history and re-upload it, you may need to upgrade your subscription plan based on the transaction volume of the fiscal year with the largest transaction volume.
Example:
In the "Bybit/Spot Trade History", there were files A (1/1/2023 - 12/31/2023) and file B (1/1/2022 - 12/31/2022). After uploading file A, this error occurred when file B was uploaded. It is necessary to specify the transaction date and time period for file A, delete the history once, and re-upload the files in the order of B → A.
(1) Specify the file type (Bybit/Spot Trade History) and date (1/1/2023 - 12/31/2023) and delete the file.
(2)Upload files in the order of B -> A.
2.Cause and solution when transactions are not uploaded due to data locked
Cause
The file contains trades from a fiscal year that has been locked (finalized)
You are trying to upload transactions for a year in which data has been confirmed and locked. Cryptact does not allow additions or edits for locked fiscal years. Uploading a file that only contains trades from a locked year will trigger this error.
▼How to check ‘Data Locking’ status: You can confirm up to which fiscal year transaction history has been locked under the ‘Data Locking’ tab within Ledger Settings.
Solution
Unlocke the data for the year of the file you want to upload, and then upload the file.
How to unlock data/update lock date?
*Please be sure to read the notes on If you unlock your data.