本ヘルプページでは、「ファイルにはアップロードすべき取引履歴が含まれていません。これはすでにアップロードされた取引であるか、取引が確定された日付である可能性があります。」の2通りの原因と解決方法について紹介します。
目次
1.「すでにアップロードされた取引である」場合の原因と解決方法
1.「すでにアップロードされた取引である」場合の原因と解決方法
原因
アップ済みの最終取引日時以前の取引履歴をアップしようとしている可能性がございます。
クリプタクトでは二重計上防止の観点より、同アップロードボックス内において、アップ済みの最終取引日時以降の履歴のみを読み込む仕様としております。そのため、最終取引日時以前の履歴しか含まれないファイルをアップしようとした場合、本エラーが発生します。
▼「最終取引日時」の確認方法:各アップロードボックス下部で確認できます。(画像例:Bybit)
解決方法
アップしたいファイルの一番古い取引日時以降の履歴を取引一覧から一度削除し、取引日時が古い順番にファイルをアップし直す。
注意点
- 削除した履歴はサーバー上からも完全に削除され復元できません。
- 過去のデータを一度削除し再アップする場合、過年度の取引件数が変動し、それに応じたプランに変更していただく必要がある場合があります。
例:「Bybit/現物アカウント」において、ファイルA(2023/1/1~2023/12/31)、ファイルB(2022/1/1~2022/12/31)があった。ファイルAをアップした後、ファイルBをアップしたら本エラーが発生した。ファイルAの取引日時期間を指定し履歴を一度削除し、B→Aの順番でファイルをアップし直す必要がある。
STEP1:ファイルの種類(Bybit/現物アカウント)と日付(2023/1/1~2023/12/31)を指定し削除する。
取引履歴の削除方法
STEP2:B→Aの順番にファイルをアップする。
2.「取引が確定された日付である」場合の原因の解決方法
原因
データ確定をした年度の取引履歴をアップしようとしていることが原因です。
クリプタクトではデータ確定した年度について、取引の追加・編集などができない仕様としております。そのため、データ確定されている年度の履歴しか含まれないファイルをアップしようとしている場合、本エラーが発生します。
▼「データ確定」の確認方法:帳簿設定より、何年度までの履歴がデータ確定されているか確認できます。
解決方法
アップしたいファイルの年度のデータ確定を解除し、ファイルをアップする。
データ確定の解除方法
※必ずデータ解除に関する注意点をお読みください。