このページでは、ファイルのアップロードを仕様とした際に、「~~のファイル形式が違います」のエラーメッセージが発生した場合の原因と解決方法を紹介します。
原因
弊社で自動対応しているファイル形式(アップロード可能拡張子)と異なるファイルをアップしようとしていることが原因です。
たとえば・・
- 取引所からファイルをダウンロードする際、CSVとExcelが選択できた。クリプタクトはCSVに対応しているのに、Excelをアップロードしようとしている。
- 取引所からダウンロードしたファイルがZIP形式であった。クリプタクトはZIP解凍後のファイルに対応しているのに、解凍せずにアップロードしようとしている。
- 取引所からファイルをダウンロードする際、ファイル形式が自動で変換されてしまい、そのファイルをアップロードしようとしている。(※この場合、ご自身のPC環境・設定などをご確認ください。)
解決方法
クリプタクトで対応しているファイル形式(アップロード可能拡張子)のファイルを再度ダウンロードし、アップロードし直してください。
取引履歴ファイルのダウンロード方法
なお、対応しているファイル形式は、各取引所の各アップロードボックスによって異なります。
該当のアップロードボックス上にある「アップロード条件」内の「アップロード可能拡張子」より確認してください。
▼画像例:SBIVC/トレードのアップロード可能拡張子はCSV